Dyverso Particles randomly changing IDs

Post here anything related to RealFlow that doesn't specifically belong in any of the forums below
Post Reply
Leo89
Posts: 1
Joined: Fri Jan 20, 2017 1:30 pm

Dyverso Particles randomly changing IDs

Post by Leo89 » Fri Jan 20, 2017 6:10 pm

Hi, so I've been having some problems trying to read the particle IDs exported from a Dyverso simulation in Softimage. The particles will randomly change their ID for no reason. Hybrido simulations work just fine and each particle will keep its ID throughout the whole animation. While searching the forum I found this thread where Luis Miguel mentions that this used to be a bug in Softimage and suggests to pass the particles to a container, but I suppose it doesn't apply to dyverso. I tried to use the technique in this tutorial by Luis Miguel, but even after converting the Dyverso particles to Hybrido, when importing those into Softimage, the particles will inherit the same bug with the IDs.

I just started learning Realflow so I have no idea how to fix this. I'm trying to do a sand simulation using instances of some modeled sand grains where each particle is assigned a random grain with a random color, but since the particle IDs keep changing, I keep getting this blinking effect because its like new particles are being spawned instead of having the same particles moving through space.

Here is an example of the effect https://streamable.com/2y19l

User avatar
tsn
Posts: 283
Joined: Fri Jun 11, 2010 7:22 am

Re: Dyverso Particles randomly changing IDs

Post by tsn » Thu Jan 26, 2017 8:53 am

Hi Leo89,

I know what you mean and I see the exact same issue when rendering multiple instances in Clarisse. Right now the only workaround is to reorder the particles, e.g. in XSI's ICE or with RF's graphs. But this requires that the number of particles remains constant, and the flicker will be visible when particles are removed during the simulation.

The only thing I'm not sure about is if this is a RF thing or if apps like XSI, Clarisse, etc. can't handle the IDs from RF correctly. I have to investigate on that a little more and I can't promise if I'll find a solution, but I'm interested in a fix as well.

Sorry for the inconvenience!

Cheers,
Thomas
Thomas Schlick | Next Limit Technologies

hackney
Posts: 1
Joined: Fri Dec 03, 2010 12:42 pm

Re: Dyverso Particles randomly changing IDs

Post by hackney » Fri Sep 01, 2017 1:33 pm

Hello, old thread I know but was there any joy with this one? I've got similar twitchy clouds in soft....

Thomas Schlick
Posts: 15
Joined: Tue Aug 29, 2017 12:35 pm

Re: Dyverso Particles randomly changing IDs

Post by Thomas Schlick » Mon Sep 04, 2017 3:17 pm

Sorry, no changes. Doesn't make me very happy as well, because the methods I've been testing out only work if the number of particles remains constant over the entire simulation. Furthermore they're not very fast and create lots of secondary data.
Thomas Schlick (tsn) | Next Limit Technologies

Post Reply